D5803 wifi not turning on, apparently no solutions, any similar experiences?

After around 14 months of happily using my xperia Z3 compact I have encountered my second major problem with the device. Around 2 weeks ago after setting up a portable hotspot on my phone my phone began to get buggy and not work properly, it would reboot itself without any user input and then it stopped connecting to wifi. The bluetooth still works and I can still make and receive calls and texts.

At this point I tried all the usual fixes listed on forums such as hard and soft reset, updating to latest OS and rebooting in safe mode. I haven't tried repair via PCC or messing around with "roots" as the USB port on my phone is broken and I can't connect my phone to my computer. So as all the usual stuff didn't work I did some digging and stumbled across a thread on xda-developers, in which there are a number of people with the exact same problem as me. They had also tried pretty much everything and nothing solved the problem, except for random repeated diagnostics testing.

I then discovered an interesting quirk of the problem after reading that thread, if I ran a diagnostics test wifi and bluetooth would pass everytime and GPS would fail the diagnostic test.

I would be interested to hear if any other users have had similar experiences and potential fixes for this problem as from what I have seen at least there is no guaranteed fix.

I will be cross-posting this on other forums and will link/share anything interesting and relevant that those posts produce. Thanks in advance.

Show Accepted Answer

Guest Quick Reply (No URL, BBcode or HTML)

Last post by mokeefe
2 hours ago
Last post by may.bode
1 hour ago
Last post by laney.waters
4 hours ago
Last post by lubowitz.brenna
1 hour ago
Last post by wallace32
2 hours ago
Last post by anastacio27
4 hours ago
Last post by daphney12
2 hours ago
Last post by wilbert20
37 minutes ago