[Q]Google Play No Connection On China MTK Phone

Hey, guys. I am not native English speaker, sorry for my English.
I bought a China Smartphone Haier HT-I860, technical details are here:
CPU: MediaTek MT6589
RAM: 1GB
ROM(eMMC): 4GB
Screen: 5 inch qHD(960x540) TFT screen
Cell network: TD-SCDMA / GSM and dual SIM card
Android version: 4.2.1
Kernel version: 3.4.5
I made a CWM recovery for this phone and flash Gapps (20130812 version from goo.im) into it. Everything works fine except Google Play. Everytime I click Google Play, it shows that "No connection, Retry". I am sure that my Wi-Fi network is OK. Other Google APP like Google Plus, Gmail, Google Voice Search works fine.
I have tried many method to solve this problem, like wipe /data and /cache, wipe dalvik cache, edit /etc/hosts, flash other version Gapps. All of these are *useless*. I think there are something wrong with this android build or library.
I have contact Haier customer service, they only send me a old version ROM. I tried and still have this problem.

I updated this ROM into Baidu.com. You can download it from
If you want log or any other thing, please reply this post and tell me how to get it. I don't know how to get log or more.
Thanks

Show Accepted Answer

Guest Quick Reply (No URL, BBcode or HTML)

Last post by walker.emile
2 hours ago
Last post by considine.rodger
2 hours ago
Last post by aliya.batz
59 minutes ago
Last post by elna43
2 hours ago
Last post by nelle62
4 hours ago
Last post by zrussel
2 hours ago
Last post by borer.cindy
3 hours ago