Link2SD worked for one year suddenly stops to identify Ext2 in SD

Hi Everybody, I am newly registered in xda, using a Samsung Galaxy K Zoom (SM-C115, baseband version C115ZSU1AOH1, kernel version 3.4.39-1837070, build number KOT49H.C115ZSU1AOH1)

I have rooted and have been using Link2SD on this phone for about one year without any problem (many thanks to all those who have so kindly contributed the necessary information in this respect), moving almost all possible apps to the ext2 partition on SD (created by Mini Partition on a PC), except Titanium Backup and Link2SD. The only problem was that Lind2SD could not automatically re-link updated apps (although settings made), requiring me to check and re-link them manually from time to time.

The other day I woke to find, upon turning on the phone, that Link2SD could not read ext2 anymore. Even when I tried to recreate mount scripts times and again, it showed an error message "Mount script cannot be created. mount: Invalid argument." Uninstalling and reinstalling Link2SD did not help.

I browsed through similar threads in xda only to find other people having problems right at the beginning of installing Link2SD, not encountering problems after having used the app for some time.

While missing user apps can be reinstalled on this phone, Google Play Store (partially on ext2) cannot be restored by Titanium Backup, nor will it work even I downloaded it from other sources like apk4fun.com and installed it. Also now I cannot log on to my Google account.

I know probably a hard phone reset and re-partitioning the SD, reinstalling Link2SD might solve the problem, unless a physical error appears in ext2, which I believe is not very likely for an original two year old Samsung SD. However, I hope to find a faster and less cumbersome solution, if at all possible.

Please help!

Show Accepted Answer

Guest Quick Reply (No URL, BBcode or HTML)

Last post by lcarter
56 minutes ago
Last post by koch.vaughn
2 hours ago
Last post by aufderhar.jaylen
2 hours ago
Last post by ron.kihn
4 hours ago
Last post by elfrieda.littel
4 hours ago
Last post by gage39
28 minutes ago