Error: application requires newer version of SDK

Hi all! I have searched the net and saw that several people had the same problem, but haven't found a solution.

I have an HTC One running Android 4.1.2 on the stock Sense ROM. I flashed Android 4.4 with Sense 5.5, but decided I wanted to go back for now, so I restored my backup using TWRP recovery. I am back on 4.1.2. Now when I want to update Google Maps through Google Play, the download starts, but I get an error saying "application requires newer version of SDK". I have tried wiping the data of Google Play, wiping cache and dalvik in TWRP, even doing a full recovery to my saved backup one more time, but no success.

Any solutions appreciated. Thanks!

Show Accepted Answer

Guest Quick Reply (No URL, BBcode or HTML)

Last post by ykassulke
1 hour ago
Last post by lawson.mckenzie
47 minutes ago
Last post by pspinka
2 hours ago
Last post by areinger
45 minutes ago
Last post by rward
1 hour ago
HBOOT help!!
Started by ymosciski
Last post by hobart79
35 minutes ago
Last post by lyric.bergstrom
3 hours ago
Last post by baby.witting
2 hours ago
Last post by ashlynn52
1 hour ago
Last post by sporer.deshawn
1 hour ago