Huge problem with memory

Hello, I have updated to Cyanogenmod 7.1.0. (stable version) and installed gapps on my phone (HTC Legend, rooted) but after that android market didn't work. So I decided to reinstall gapps with recovery thing (vol. down + power button) and after that some strange artefacts started over phone's screen. So, when I power up phone it behaves normally but I can't access my SD card (goldcard) and in settings > storage > is says that "total space" and "available space" are unavailable and I can't press mount SD. When i try to mount my phone via USB cable on pc, only USB debugging pops up and i can't mount my internal or SD card storage. After some time even USB debugger is stopping to work.
I tried to factory reset it but it didn't help. When I plug in my phone i get errors like "Windows has stopped this device because it has reported problems. (Code 43)" or "This device cannot start. (Code 10)". Also, when i shut down my legend and power up it , the first "htc" white screen keeps blinking untill i plug usb cable and then i can normally enter in ROM.
Can you please help me with my problem or do you think that my phone became a brick?

Show Accepted Answer

Guest Quick Reply (No URL, BBcode or HTML)

Last post by monte16
4 hours ago
Last post by larry80
4 hours ago
Last post by virgie.fay
1 hour ago
Last post by kaylee.grant
2 hours ago
Last post by emanuel71
55 minutes ago
Last post by isabel49
2 hours ago
Last post by lily.lakin
1 hour ago
Last post by chasity.waters
3 hours ago
Last post by wiegand.janick
2 hours ago
Last post by gmorar
2 hours ago
Last post by hspinka
51 minutes ago