PLEASE HELP: Problem with AOSP ROM in Mi A1

Hey, I'm having a problem with updating my MiA1 using TWRP since january patch. Here's is, more or less, what's happening. AOSP Pie with december security patch is working flawless. I can reinstall this .zip with TWRP whenever I want.

But since january ROM, I'm having the same problem: if I install january/february patch, everytime I boot the phone, with or without gapps installed, the phone continues with a black screen after the Mi logo and nothing happens. Actually, if I double press the power button, the phone vibrates (as if the camera was opening) and if I single press it, the nav bar acts like im locking;unlocking the phone.

What I did:
-Checked with MD5. No error found
-Downloaded boot.img from the latest stock ROM from Xiaomi oficial site (same patch as AOSP).
-Installed boot.img without gapps: the screen works
-Installed boot.img before AND after installing gapps: bootloop in both cases.
-February update done with a clean install and over december patch: black screen as well

Can someone please help me? I don't know what I'm missing and don't want to get stuck with an older update.

I'm sorry if I missed something, kinda of a noob here

Show Accepted Answer

Guest Quick Reply (No URL, BBcode or HTML)

Last post by elbert26
49 minutes ago
Last post by skiles.alexandre
2 hours ago
Last post by crona.lucy
2 hours ago
Last post by yblick
2 hours ago
Last post by barrows.destany
24 minutes ago
Last post by eliezer79
4 hours ago
Last post by donato.doyle
1 hour ago
Last post by kaltenwerth
30 minutes ago
Last post by martin.bailey
2 hours ago
Last post by corine.kohler
4 hours ago
Last post by barbara83
4 hours ago
Last post by dillon38
1 hour ago
Last post by charley.waters
42 minutes ago
Last post by qcarter
2 hours ago
Last post by goodwin.katarina
4 hours ago
Last post by nia98
4 hours ago
Last post by vella91
40 minutes ago