Android Auto fails to establish Bluetooth connection with Car Infotainment using Moto E4 Plus Phone?

I am facing lot of issues related to Bluetooth Connection while connecting my phone and Car Infotainment using Android Auto. The problems and other required details are listed as below:

1.On connecting the Phone and Head Unit with USB Cable, Android Auto gets connected but the Phone Tile (Tab) of Android Auto Display shows an error message "To make or receive calls, connect your phone to your car via Bluetooth" whereas the Phone BT Status shows the devices as connected/paired.
2.On connecting the Phone and Head Unit with USB Cable, Android Auto gets connected but the Incoming Call to Head Unit doesn't get connected via Car Speakers. Instead the Incoming Call Ringtone and the Call Audio is heard from Phone Speakers only.

Error message: To make or receive calls, connect your phone to your car via Bluetooth

•Car / head unit make & model: Maruti Suzuki New DZIRE Car Infotainment Unit (SLDA)

•Phone make & model: Motorola - E4 Plus

•Android OS version : 7.1.1

•Android Auto app version: 2.8.574513

The Problem is Sporadic i.e. sometimes Android Auto works fine with all its features but sometimes I face above issues.

Show Accepted Answer

Guest Quick Reply (No URL, BBcode or HTML)

Last post by mpfeffer
3 hours ago
Last post by owisozk
5 hours ago
Last post by joyce42
2 hours ago
Last post by christina61
12 minutes ago
Last post by moriah79
50 minutes ago
Last post by iva.donnelly
4 hours ago
Last post by lynn.anderson
2 hours ago
Last post by ivah40
3 hours ago